Deycom Computer Services - Upstream Provider issues – Incident details

All systems operational

Upstream Provider issues

Resolved
Operational
Started 3 days agoLasted about 2 hours

Affected

VOIP Trunks

Operational from 8:40 AM to 10:51 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We are experiencing issues with our upstream provider, affecting incoming and outgoing calls. We are currently investigating this incident.